View Issue Details

IDProjectCategoryView StatusLast Update
0000132Multi Theft Auto[All Projects] Serverpublic2018-09-03 04:45
ReporterSugarD-xAssigned ToSugarD-x 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.6 
Target Version0.6Fixed in Version0.6 
Summary0000132: Mac OS X server builds are causing MTAClient connections to timeout upon connecting
DescriptionMac OS X server builds see MTAClient connection attempts and log them as connected, however MTAClient connections are dropped during the process, resulting in timeout errors for MTAClient. This may or may not also affect Linux builds under Ubuntu.
Steps To ReproduceBuild MTAServer in Mac OS X. Attempt to connect to MTAServer using MTAClient. MTAClient will repeatedly timeout on connection attempts and not see MTAServer, however MTAServer will see MTAClient connect successfully and then timeout.
Additional InformationThis may be related to compiler or linker optimizations removing functions needed by MTAServer, similar to bug 0000130.
TagsNo tags attached.

Activities

SugarD-x

SugarD-x

2018-09-03 04:45

administrator   ~0000169

This was caused by an unusual port forwarding issue on a system with multiple network interface cards.

Issue History

Date Modified Username Field Change
2018-09-01 20:03 SugarD-x New Issue
2018-09-01 20:08 SugarD-x Assigned To => SugarD-x
2018-09-01 20:08 SugarD-x Status new => confirmed
2018-09-03 04:45 SugarD-x Status confirmed => resolved
2018-09-03 04:45 SugarD-x Resolution open => fixed
2018-09-03 04:45 SugarD-x Fixed in Version => 0.6
2018-09-03 04:45 SugarD-x Note Added: 0000169