View Issue Details

IDProjectCategoryView StatusLast Update
0000043Multi Theft Auto[All Projects] Clientpublic2018-01-06 17:45
ReporterJaysds1Assigned Toixjf 
PriorityurgentSeveritymajorReproducibilityalways
Status feedbackResolutionreopened 
PlatformOSWindowsOS VersionXP Service Pack3
Product Version 
Target Version0.6Fixed in Version 
Summary0000043: Error after connecting again
DescriptionWhen I disconnect from my server and try to connect again, the error in the attached image comes up.
Steps To Reproduce1. Connect to a server
2. Disconnect after
3. Try connecting to it again
4. Error comes up
Tagsagain, client, connect, error

Activities

SugarD-x

SugarD-x

2012-11-20 03:36

administrator   ~0000024

This doesn't appear to happen in Windows 7 or 8. The user's Operating System is Windows XP SP3, so it's possible that it's OS-specific. Someone with Windows XP SP3 needs to check and confirm the status of this error.
SugarD-x

SugarD-x

2012-11-20 17:53

administrator   ~0000026

This bug has been confirmed to have been fixed in Microsoft Windows XP SP3, in the latest development build. If it happens again after the next public release, report back with any additional details you can provide.
Jaysds1

Jaysds1

2013-04-15 08:31

reporter   ~0000031

ok, As my old pc(Windows XP) is currently being fixed, I'm currently using my moms laptop which is a Windows 7 Home Premium.
And since I'm not sure about this issue with Windows XP, I've just noticed that it's also happening on Windows 7 Home Premium.
SugarD-x

SugarD-x

2013-04-15 11:27

administrator   ~0000032

Did you use the latest development build, (nightly), as requested?
Jaysds1

Jaysds1

2013-04-15 17:12

reporter   ~0000033

"Nightly_r2"?
Ya
SugarD-x

SugarD-x

2013-04-15 18:20

administrator   ~0000034

Last edited: 2013-04-15 18:21

View 2 revisions

Noted. Please let us know if you are able to reproduce it consistently using a specific method every time.

SugarD-x

SugarD-x

2013-04-15 18:21

administrator   ~0000035

The issue will be looked into, and we will attempt to reproduce it to find the cause.
Jaysds1

Jaysds1

2013-04-16 14:59

reporter   ~0000036

Last edited: 2013-04-16 14:59

View 2 revisions

hmmm, well I'm not sure how to explain it more, but I'll tell you in steps.
1. Start your own server via MTAServer.exe
2. Connect to it with MTAClient.exe
3. Disconnect and wait for button to be enabled again
4. Try connecting to server again without changing anything

I usually use "localhost" as host and "2003" as port.

I'm going to try recording it later this week.

SugarD-x

SugarD-x

2013-04-16 15:05

administrator   ~0000037

Does this happen when you connect to "127.0.0.1" instead of "localhost"?
Jaysds1

Jaysds1

2013-04-17 10:16

reporter   ~0000038

Last edited: 2013-04-17 10:40

View 2 revisions

ya
Here's a video: http://youtu.be/dcjhZ5oIavU

SugarD-x

SugarD-x

2013-04-17 12:33

administrator   ~0000039

Thank you. I'll look into it and try to reproduce it.

(Just a heads up, by the way...it's called "GTA3:MTA", not "MTA:3" ;) )
Jaysds1

Jaysds1

2013-04-17 12:33

reporter   ~0000040

Damn, I don't know why i mix them up, thanks :D
SugarD-x

SugarD-x

2013-04-17 12:35

administrator   ~0000041

Not a problem. Thanks for the HD too! :)
Jaysds1

Jaysds1

2013-04-17 12:52

reporter   ~0000042

lol, No Problem :D
SugarD-x

SugarD-x

2015-04-01 07:52

administrator   ~0000046

This issue seems to be resolved in future versions of the Release build, however it has not yet been tested on Nightly and Debug builds.
SugarD-x

SugarD-x

2015-04-09 21:15

administrator   ~0000056

This needs to be heavily tested in the latest development build to see if the issue still occurs.
SugarD-x

SugarD-x

2015-04-14 13:10

administrator   ~0000064

This bug is still present as of the latest development build.
ixjf

ixjf

2015-04-14 13:12

developer   ~0000065

I can still reproduce this issue.
SugarD-x

SugarD-x

2018-01-06 17:44

administrator   ~0000114

Does this still occur in 0.6 Nightly 2?

Issue History

Date Modified Username Field Change
2012-10-06 19:02 Jaysds1 New Issue
2012-11-17 17:30 SugarD-x File Added: 1g9Xk.png
2012-11-17 17:31 SugarD-x Description Updated View Revisions
2012-11-20 03:36 SugarD-x Note Added: 0000024
2012-11-20 17:53 SugarD-x Note Added: 0000026
2012-11-20 17:53 SugarD-x Status new => resolved
2012-11-20 17:53 SugarD-x Fixed in Version => 0.6
2012-11-20 17:53 SugarD-x Resolution open => fixed
2012-11-20 17:53 SugarD-x Assigned To => SugarD-x
2013-04-15 08:27 Jaysds1 Tag Attached: again
2013-04-15 08:27 Jaysds1 Tag Attached: client
2013-04-15 08:27 Jaysds1 Tag Attached: connect
2013-04-15 08:27 Jaysds1 Tag Attached: error
2013-04-15 08:31 Jaysds1 Note Added: 0000031
2013-04-15 08:31 Jaysds1 Status resolved => feedback
2013-04-15 08:31 Jaysds1 Resolution fixed => reopened
2013-04-15 11:27 SugarD-x Note Added: 0000032
2013-04-15 17:12 Jaysds1 Note Added: 0000033
2013-04-15 17:12 Jaysds1 Status feedback => assigned
2013-04-15 18:20 SugarD-x Note Added: 0000034
2013-04-15 18:21 SugarD-x Note Added: 0000035
2013-04-15 18:21 SugarD-x Status assigned => acknowledged
2013-04-15 18:21 SugarD-x Note Edited: 0000034 View Revisions
2013-04-16 14:59 Jaysds1 Note Added: 0000036
2013-04-16 14:59 Jaysds1 Note Edited: 0000036 View Revisions
2013-04-16 15:05 SugarD-x Note Added: 0000037
2013-04-17 10:16 Jaysds1 Note Added: 0000038
2013-04-17 10:40 Jaysds1 Note Edited: 0000038 View Revisions
2013-04-17 12:33 SugarD-x Note Added: 0000039
2013-04-17 12:33 Jaysds1 Note Added: 0000040
2013-04-17 12:35 SugarD-x Note Added: 0000041
2013-04-17 12:52 Jaysds1 Note Added: 0000042
2015-03-12 16:16 SugarD-x Assigned To SugarD-x =>
2015-03-12 16:16 SugarD-x Assigned To => SugarD-x
2015-03-12 16:16 SugarD-x Status acknowledged => assigned
2015-04-01 07:52 SugarD-x Note Added: 0000046
2015-04-09 21:15 SugarD-x Note Added: 0000056
2015-04-09 21:15 SugarD-x Status assigned => feedback
2015-04-14 13:10 SugarD-x Note Added: 0000064
2015-04-14 13:11 SugarD-x Status feedback => confirmed
2015-04-14 13:12 ixjf Note Added: 0000065
2015-04-14 13:12 ixjf Assigned To SugarD-x => ixjf
2015-04-14 13:12 ixjf Status confirmed => assigned
2018-01-06 17:44 SugarD-x File Deleted: 1g9Xk.png
2018-01-06 17:44 SugarD-x Note Added: 0000114
2018-01-06 17:44 SugarD-x Status assigned => feedback
2018-01-06 17:45 SugarD-x Fixed in Version 0.6 =>
2018-01-06 17:45 SugarD-x Target Version => 0.6